07 November 2008

Add-In for Outlook 2003 and 2007

MSDN Documentation states that: ‘There is no supported way to use VSTO to create add-in that that works on both Outlook 2003 and 2007.’
But actually it is possible to make add-in for Outlook 2003 which works on Outlook 2007 because VSTO 3.0 runtime can detect that add-in is made for previous version of Outlook and can set environment for it.
However, backward compatibility is not possible.
Additional difficulty is that Outlook 2003 and 2007 can’t work on the same machine, which makes development and testing a little bit harder than usual.

No comments:

Post a Comment